Networking
HOW TO CONFIGURE THE GRE TUNNEL ON CISCO ROUTER WITH OSPF PROTOCOL
1.check the diagram and follow the steps as mention below .
Router 1 in that execute this command
!
interface FastEthernet0/0
ip address 20.1.1.1 255.255.255.252
duplex auto
speed auto
interface Tunnel10
ip address 172.16.1.2 255.255.255.252
tunnel source Loopback0
tunnel destination 1.1.1.1
!
interface FastEthernet0/0
ip address 40.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 30.1.1.2 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 100
network 2.2.2.0 0.0.0.255 area 100
network 3.3.3.0 0.0.0.255 area 100
network 10.1.1.0 0.0.0.255 area 100
network 20.1.1.0 0.0.0.255 area 100
network 30.1.1.0 0.0.0.255 area 100
network 40.1.1.0 0.0.0.255 area 100
verify the tunnel 10 through traceroute command
R1#traceroute 172.16.1.2
Type escape sequence to abort.
Tracing the route to 172.16.1.2
1 172.16.1.2 92 msec 64 msec 48 msec
R3#traceroute 172.16.1.1
Type escape sequence to abort.
Tracing the route to 172.16.1.1
1 172.16.1.1 100 msec 72 msec 60 msec
****************finished************
HOW TO CONFIGURE THE GRE TUNNEL ON CISCO ROUTER WITH OSPF PROTOCOL
1.check the diagram and follow the steps as mention below .
Router 1 in that execute this command
R1#
conf t
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel10
ip address 172.16.1.1 255.255.255.252
tunnel source Loopback0
tunnel destination 3.3.3.3
ip address 1.1.1.1 255.255.255.255
!
interface Tunnel10
ip address 172.16.1.1 255.255.255.252
tunnel source Loopback0
tunnel destination 3.3.3.3
no shut
!
interface FastEthernet0/0
ip address 20.1.1.1 255.255.255.252
duplex auto
speed auto
no shut
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
no shut
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 100
network 2.2.2.0 0.0.0.255 area 100
network 3.3.3.0 0.0.0.255 area 100
network 10.1.1.0 0.0.0.255 area 100
network 20.1.1.0 0.0.0.255 area 100
network 30.1.1.0 0.0.0.255 area 100
network 40.1.1.0 0.0.0.255 area 100
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 100
network 2.2.2.0 0.0.0.255 area 100
network 3.3.3.0 0.0.0.255 area 100
network 10.1.1.0 0.0.0.255 area 100
network 20.1.1.0 0.0.0.255 area 100
network 30.1.1.0 0.0.0.255 area 100
network 40.1.1.0 0.0.0.255 area 100
Router 2 execute this below commands
R2#
conf t
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 20.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 30.1.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 100
network 2.2.2.0 0.0.0.255 area 100
network 3.3.3.0 0.0.0.255 area 100
network 10.1.1.0 0.0.0.255 area 100
network 20.1.1.0 0.0.0.255 area 100
network 30.1.1.0 0.0.0.255 area 100
network 40.1.1.0 0.0.0.255 area 100
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 20.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 30.1.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 100
network 2.2.2.0 0.0.0.255 area 100
network 3.3.3.0 0.0.0.255 area 100
network 10.1.1.0 0.0.0.255 area 100
network 20.1.1.0 0.0.0.255 area 100
network 30.1.1.0 0.0.0.255 area 100
network 40.1.1.0 0.0.0.255 area 100
R3#
Router 3
execute this below command
conf t
ip address 172.16.1.2 255.255.255.252
tunnel source Loopback0
tunnel destination 1.1.1.1
!
interface FastEthernet0/0
ip address 40.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 30.1.1.2 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 100
network 2.2.2.0 0.0.0.255 area 100
network 3.3.3.0 0.0.0.255 area 100
network 10.1.1.0 0.0.0.255 area 100
network 20.1.1.0 0.0.0.255 area 100
network 30.1.1.0 0.0.0.255 area 100
network 40.1.1.0 0.0.0.255 area 100
verify the tunnel 10 through traceroute command
R1#traceroute 172.16.1.2
Type escape sequence to abort.
Tracing the route to 172.16.1.2
1 172.16.1.2 92 msec 64 msec 48 msec
R3#traceroute 172.16.1.1
Type escape sequence to abort.
Tracing the route to 172.16.1.1
1 172.16.1.1 100 msec 72 msec 60 msec
****************finished************
No comments:
Post a Comment